Random level resets

I'm on the latest version, "ZLevels Remastered" (3.1.7) by nivex (0.42s) - ZLevelsRemastered.cs, and from time to time I'll have someone let me know that ZLevels reset. In the config I have "Wipe Data OnNewSave": false so I'm not sure what's going on. Never really had any issues with this plugin the last few years

it's not going to reset unless the data file is corrupted (null) when the wipe option is false

@turner maybe we can compare plugins or recent changes, I am having same issue. Something must be corrupting the data file

nivex

it's not going to reset unless the data file is corrupted (null) when the wipe option is false

Copy, didn't think about that.

WHlDhnBnUVqbUlF.png TheRustingDeadRick

@turner maybe we can compare plugins or recent changes, I am having same issue. Something must be corrupting the data file

I'm not having the issue anymore or no one is saying anything about it. I checked the data file recently and no one seems to be back at Level 1. It must have fixed iteself but I'd probably take nivex's suggestion about the data file. If I would have known earlier about that I would have just deleted the data file and reloaded the plugin.

Turner

Copy, didn't think about that.

I'm not having the issue anymore or no one is saying anything about it. I checked the data file recently and no one seems to be back at Level 1. It must have fixed iteself but I'd probably take nivex's suggestion about the data file. If I would have known earlier about that I would have just deleted the data file and reloaded the plugin.

good to know! I will do the same, thanks for the reply.

Edit: I just remembered that at one point i did notice the string "gameProtocol": 2356, was incorrectly set to "gameProtocol": 2359, not sure if this is relevant or not. Edit2: Now its 2362...I have no idea what this number means lol

 

tYlD1S1LoJDNQWG.png TheRustingDeadRick

good to know! I will do the same, thanks for the reply.

Edit: I just remembered that at one point i did notice the string "gameProtocol": 2356, was incorrectly set to "gameProtocol": 2359, not sure if this is relevant or not. Edit2: Now its 2362...I have no idea what this number means lol

 

Can you change the status to "solved"  :)

nMyfFlEnglczTD3.jpg pookins

Can you change the status to "solved"  :)

Its not solved for me. Did a complete reinstall of the plugin and another on my test server. Seems to be resetting on every server restart.

Sadly, too many issues with this plugin and the players become to reliant on it. Uninstalling. If this ever gets fixed will reinstall.

oSm9sSSJymAosZM.png TheRustingDeadRick

Its not solved for me. Did a complete reinstall of the plugin and another on my test server. Seems to be resetting on every server restart.

Sadly, too many issues with this plugin and the players become to reliant on it. Uninstalling. If this ever gets fixed will reinstall.

post your config , someone might spot an error in there

Having the same issue. Today I realized there was an update to perform. Did the update, updated Oxide files and the server itself. When it came back online, everyone's levels reset back to level 1. Has been working just fine till today's update. Now I have pissed off players, but nonetheless, they know things happen, just sucks.

Tried to rollover as well with backed up folders (do every time before updating), and it works, but then restarted the server, and it's gone again. Not sure why it's resetting it, but it's happening.

Edit: Reinstall backed up data files to the correct folder. Then reload the plugin, and they all still sit at level 1.

Just restarted my server and Zlevels loaded to same levels as they were before the restart, I am not sure why your configs dont work, they validate ok, they only thing i can think of is that you have another plugin that is conflicting with it,

Although i realise you are having no success with this plugin it is not usual for posters to advertise plugins from another site especially as this plugin is free and the other is a paid one

nMyfFlEnglczTD3.jpg pookins

Just restarted my server and Zlevels loaded to same levels as they were before the restart, I am not sure why your configs dont work, they validate ok, they only thing i can think of is that you have another plugin that is conflicting with it,

Although i realise you are having no success with this plugin it is not usual for posters to advertise plugins from another site especially as this plugin is free and the other is a paid one

Well what I don't get, is we're using the same plugins for the last 6-8 months. Never added new ones yet, and yesterday's update for both the server and Oxide get put in, and now having this issue with it. So that's why it doesn't make sense. If a plugin was conflicting with it, why wouldn't it do that before yesterday's update?

UPDATE: So I set everyone's levels to 15. Did a "server.save" and "server.writecfg". Restarted server, they remain at level 15 now. So not sure what's really going on now for sure, but thought this may help others, since it won't take the backedup files back in either.

nMyfFlEnglczTD3.jpg pookins

Just restarted my server and Zlevels loaded to same levels as they were before the restart, I am not sure why your configs dont work, they validate ok, they only thing i can think of is that you have another plugin that is conflicting with it,

Although i realise you are having no success with this plugin it is not usual for posters to advertise plugins from another site especially as this plugin is free and the other is a paid one

I meant no offense, I still endorse this plugin - just not as it is now.

I tested on a vanilla server 0 plugins.

IF there is a conflict I am not skilled enough to find it.

I still love ZLevels! If you are having the ZLevels reset and are at your wits end, then here is a paid solution that works for me. Hopefully somebody can figure out why people are having issues. Would love to keep running ZLevels.

Locked