Install available on Linux?Solved

Thanks, needed to know which step you were on.

That issue is fixed now.

You sure?
I have exactly the same problem.

RustyRoot

You sure?
I have exactly the same problem.

Yes, that specific error was fixed in the install scripts.

Not to me.
I've exactly the same problem.

In a new machine it works, in a machine with old umod version previously installed it is not working.

RustyRoot

Not to me.
I've exactly the same problem.

In a new machine it works, in a machine with old umod version previously installed it is not working.

Sounds like the old machine is caching the ole script. The script is updated on our end, so the steps from the beginning should work fine.

ok.
You forgot to fix this:
"
dlopen failed trying to load:
steamclient.so
with error:
steamclient.so: wrong ELF class: ELFCLASS32
[S_API FAIL] SteamAPI_Init(): Sys_LoadModule failed to load: steamclient.so
[S_API FAIL] SteamAPI_Init() failed"

Just to alert..

That is another issue we need to account for that has to do with Steam. You can fix it by manually moving or copying the steamclient.so from linux64 to your main install location and replacing the existing steamclient.so.

Not forgotten about, just on the list to do and only applies to Linux.

**Another problem..

"Unable to update game, uMod core, or uMod apps. Starting server anyway...
Starting server...

CAppInfoCacheReadFromDiskThread took 0 milliseconds to initialize
CApplicationManagerPopulateThread took 0 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
RecordSteamInterfaceCreation (PID 2269): SteamGameServer012 / GameServer
RecordSteamInterfaceCreation (PID 2269): SteamUtils009 / Utils
src/tier1/fileio.cpp (4914) : Assertion Failed: s_bExit
src/tier1/fileio.cpp (4916) : Assertion Failed: m_vecRegisteredWriters.Count() == 0
Bad thread localsrc/tier1/fileio.cpp (4976) : Assertion Failed: CFileWriterThread already exited
Bad thread localBad thread localsrc/tier1/fileio.cpp (4976) : Assertion Failed: CFileWriterThread already exited
Bad thread local"

After a fresh valheim + umod install.

TVAANgOX9tvOW60.jpg Wulf

That is another issue we need to account for that has to do with Steam. You can fix it by manually moving or copying the steamclient.so from linux64 to your main install location and replacing the existing steamclient.so.

yeah, you already explained me before ;) 
But after fixing, now is giving me a new problem... 

Merged post

Tried in a different server machine, but the same is happening.

What is the new problem?

Already explained in the last messages.

RustyRoot

**Another problem..

"Unable to update game, uMod core, or uMod apps. Starting server anyway...
Starting server...

CAppInfoCacheReadFromDiskThread took 0 milliseconds to initialize
CApplicationManagerPopulateThread took 0 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
RecordSteamInterfaceCreation (PID 2269): SteamGameServer012 / GameServer
RecordSteamInterfaceCreation (PID 2269): SteamUtils009 / Utils
src/tier1/fileio.cpp (4914) : Assertion Failed: s_bExit
src/tier1/fileio.cpp (4916) : Assertion Failed: m_vecRegisteredWriters.Count() == 0
Bad thread localsrc/tier1/fileio.cpp (4976) : Assertion Failed: CFileWriterThread already exited
Bad thread localBad thread localsrc/tier1/fileio.cpp (4976) : Assertion Failed: CFileWriterThread already exited
Bad thread local"

After a fresh valheim + umod install.

If this is the error you mean, that doesn't appear to be related to uMod.

Hum..
Ok mate ;)

When updating though, make sure the sever is not running.

I reinstalled all my servers and everything worked well ;)
Thanks to fix it..

Merged post

Another problem..
Command not working.
It says that is updated but it is not updating.
umod update valheim --dir="/root/valheim/valheim_server_Data" -P

Merged post

*I mean command: umod update valheim --dir="/root/valheim" -P
It is downloading everything the wrong way.

Locked automatically