Install available on Linux?Solved

umod/plugins is the default.

**Oh, i already found it.
After first run the folders are now created ;)

Merged post

The plugin to edit the slots, it works right?

Yes, the client has a visual limit though.

Anyway to put the server always on with umod? 
Cause if i close the putty window, the server shuts down :/

That doesn't really have anything to with uMod, you'd need to set up a "screen" on your server.

yeah, i understand..

but if you can add to the tutorial, so new users know how to do it, it will be a good help ;)

Merged post

"The specified framework can be found at:
- https://aka.ms/dotnet-core-applaunch?framework=Microsoft.NETCore.App&framework_version=3.1.0&arch=x64&rid=debian.10-x64"


This is the message that users arew seeing when trying to install umod following the tutorial: https://umod.org/guides/development/umod-installation-pre-release

regards

1IFNXLooTcocLdL.jpg Wulf
That is not a solution, as all our tools use .NET 5.0 now. I'll be looking into a fix relevant to that.

Thank you ;)   

The scripts have been updated and should be working fine now by the way. Do not modify the dotnet-install script as suggested above, that will not work for our tools.

I'll give it a try again..

Merged post

"Specified version 'umod-install.sh' is not a valid NuGet version range."

Could you provide more details on when you saw that and with what exactly? I'm trying to reproduce what you are doing, but can't so far.

I'm just following the command you published xD
New Debian 10.8 x64 machine, then i just:
apt-get update
apt-get upgrade
curl -sSL https://umod.io/umod-develop.sh | bash /dev/stdin
_ _ __ __ ___ ____
| | | | \/ |/ _ \| _ \
| | | | |\/| | | | | | | |
| |_| | | | | |_| | |_| |
\___/|_| |_|\___/|____/

Downloading dotnet-install...
dotnet-install: Note that the intended use of this script is for Continuous Integration (CI) scenarios, where:
dotnet-install: - The SDK needs to be installed without user interaction and without admin rights.
dotnet-install: - The SDK installation doesn't need to persist across multiple CI runs.
dotnet-install: To set up a development environment or to run apps, use installers rather than this script. Visit https://dotnet.microsoft.com/download to get the installer.

dotnet-install: .NET Core SDK version 5.0.103 is already installed.
dotnet-install: Adding to current process PATH: `/root/.dotnet`. Note: This change will be visible only when sourcing script.
dotnet-install: Note that the script does not resolve dependencies during installation.
dotnet-install: To check the list of dependencies, go to https://docs.microsoft.com/dotnet/core/install, select your operating system and check the "Dependencies" section.
uMod install complete!lation finished successfully.
[email protected]:~#
Specified version 'umod-install.sh' is not a valid NuGet version range.
Usage: dotnet tool update [options] <PACKAGE_ID>

Arguments:
<PACKAGE_ID> The NuGet Package Id of the tool to update.

Options:
-g, --global Update the tool in the current user's tools directory.
--tool-path <PATH> The directory containing the tool to update.
--local Update the tool and the local tool manifest.
--configfile <FILE> The NuGet configuration file to use.
--add-source <SOURCE> Add an additional NuGet package source to use during the update.
--framework <FRAMEWORK> The target framework to update the tool for.
--version <VERSION> The version range of the tool package to update to.
--tool-manifest <PATH> Path to the manifest file.
--disable-parallel Prevent restoring multiple projects in parallel.
--ignore-failed-sources Treat package source failures as warnings.
--no-cache Do not cache packages and http requests.
--interactive Allows the command to stop and wait for user input or action (for example to complete authentication).
-h, --help Show command line help.
-v, --verbosity <LEVEL> Set the MSBuild verbosity level. Allowed values are q[uiet], m[inimal], n[ormal], d[etailed], and diag[nostic].

Locked automatically