SAM sites shooting players when flying mini copters
Is there a way to turn off Sam Sites from shooting players while flying when TruePVE is activated?
    {
      "name": "samsites",
      "members": "SamSite, sam_static, sam_site_turret_deployed",
      "exclusions": ""
    },

then add "samsites cannot hurt players" to the ruleset

This is all I can come up with, atm. Will stop samsites from hurting any player, regardless if flying or not. Flying isn't taken into account afaik, I didn't write the plugin :p
I can't seem to get this to work. What I want to do is stop players placed sams from shooting at players but allow the ones at launch to shoot as normal. Any glaring errors here?

here is my config.
{
  "Config Version": "1.1.95",
  "Default RuleSet": "default",
  "Configuration Options": {
    "handleDamage": true,
    "useZones": true
  },
  "Mappings": {
    "default": "default",
    "NPCBASE": "exclude"
  },
  "Schedule": {
    "enabled": false,
    "useRealtime": false,
    "broadcast": false,
    "entries": []
  },
  "RuleSets": [{
    "name": "default",
    "enabled": true,
    "defaultAllowDamage": false,
    "flags": "HumanNPCDamage, LockedBoxesImmortal, LockedDoorsImmortal, TurretsIgnorePlayers, TrapsIgnorePlayers",
    "rules": ["samsites cannot hurt players", "samsites_PLR cannot hurt heli", "samsites_LOR can hurt heli", "samsites cannot hurt mounts ", "anything can hurt dispensers", "anything can hurt players", "players cannot hurt players", "anything can hurt traps", "traps cannot hurt players", "players can hurt barricades", "barricades cannot hurt players", "highwalls cannot hurt players", "anything can hurt heli", "anything can hurt npcs", "fire cannot hurt players", "anything can hurt resources"]
  }],
  "Allow Killing Sleepers": false,
  "Entity Groups": [{
    "name": "dispensers",
    "members": "BaseCorpse, HelicopterDebris",
    "exclusions": ""
  }, {
    "name": "players",
    "members": "BasePlayer",
    "exclusions": ""
  }, {
    "name": "mounts",
    "members": "BaseMountable",
    "exclusions": ""
  }, {
    "name": "samsites_FP",
    "members": "sam_static, samrocket",
    "exclusions": ""
  }, {
    "name": "samsites_PLR",
    "members": "sam_site_turret_deployed",
    "exclusions": ""
  }, {
    "name": "samsites_LOR",
    "members": "ammo.rocket.smoke",
    "exclusions": ""
  }, {
    "name": "traps",
    "members": "AutoTurret, BearTrap, FlameTurret, Landmine, GunTrap, ReactiveTarget, spikes.floor, TeslaCoil, teslacoil.deployed, electric.teslacoil",
    "exclusions": ""
  }, {
    "name": "barricades",
    "members": "Barricade",
    "exclusions": ""
  }, {
    "name": "highwalls",
    "members": "wall.external.high.stone, wall.external.high.wood, gates.external.high.wood, gates.external.high.wood",
    "exclusions": ""
  }, {
    "name": "heli",
    "members": "BaseHelicopter",
    "exclusions": ""
  }, {
    "name": "npcs",
    "members": "NPCPlayerApex, BradleyAPC",
    "exclusions": ""
  }, {
    "name": "fire",
    "members": "FireBall",
    "exclusions": ""
  }, {
    "name": "resources",
    "members": "ResourceEntity, TreeEntity, OreResourceEntity",
    "exclusions": ""
  }]
}​
I posted it above already

    {
      "name": "samsites",
      "members": "SamSite, sam_site_turret_deployed",
      "exclusions": "samsite_static, sam_static"
    },​

then add "samsites cannot hurt players" to the ruleset​

this will stop player samsites from hurting players, and allow static ones such as at launch site to hurt players

i think it also works well with the flag. i don't remember though

SamSitesIgnorePlayers
we worked out something months ago on this if I remember.....

something about it NOT being The sam site that does the damage if it's a player sam...
  for players sam sites  it is the ammo, but the game does not use ammo, the sam launcher does the damage
This broke in a recent Rust update and is fixed in the next plugin update.

my solution: if you disable samsites like nivex sayed the player can fly to the top of the Launch side. I desided to disable, that player can buy Samsides, killed all player set samsites and enabled the Samsites again.

How to change compound sells: https://www.youtube.com/watch?v=_e7PhYWfBaM

as I said, it broke in a recent Rust update and is fixed in the next plugin update. please read before posting

Disregard