Using pipes with RecyclerError

Here is my situation.  I have a dump box, piped to my recycler, and then a pipe to a break down box.  My problem is this, when i put an item in the drop box it bybasses the recycler and comes out the other end as original. Do I have to set up filters for each individual item for it to work?

Yes you will need to filter the second pipe to prevent items from being moved straight through.

So annoying, jpipes does not take from the input slot of the recycler but sync pipes does. i did not need any filters when piping a recyler using jpipes.

I will have a look at it when I get a chance and see what I can do. 

NkXtLCfs4AsULh8.jpg Joe90

I will have a look at it when I get a chance and see what I can do. 

Much appreciated thank you kindly.

I think I may have a solution to the issue. I'll try and get it in the the next update.

Merged post

I think I've worked out what changed. They fixed the recycler so that you can't accidently stack into the output (when you spam right click). This means the way it handles the slots has changed and I hadn't noticed :(.

Been trying to work that out as no one seems to have reported this issue before.

Hoping for a fix soon :)

That will be fantastic Joe. Can't wait.

After I loaded the new beta version, I was greeted by this : 

(10:24:17) | NullReferenceException: Object reference not set to an instance of an object

(10:24:19) | NullReferenceException: Object reference not set to an instance of an object

(10:24:21) | NullReferenceException: Object reference not set to an instance of an object

(10:24:23) | NullReferenceException: Object reference not set to an instance of an object

(10:24:25) | NullReferenceException: Object reference not set to an instance of an object

(10:24:27) | NullReferenceException: Object reference not set to an instance of an object

(10:24:29) | NullReferenceException: Object reference not set to an instance of an object

until I reverted back to the last version. 

Very odd. I'll pull that version and look into it. 

Merged post

How many pipes do you have?
By the rate you are getting that message it looks like one container is failing on each update cycle. I'm trying to locate what might be throwing that.

Unfortunately this does not happen on my test server 😕. Do you get any more information in the logs about where this NullReferenceException is being thrown?

Merged post

Also can you let me know what mods you are running on your server in case one of those is conflicting.

How many pipes do you have?
By the rate you are getting that message it looks like one container is failing on each update cycle. I'm trying to locate what might be throwing that.

Currently : 19 pipes, 24 managers.

Unfortunately this does not happen on my test server 😕. Do you get any more information in the logs about where this NullReferenceException is being thrown?

10:26 [Info] Loaded plugin Sync Pipes v0.9.22 by Joe 90
10:26 [Info] [Sync Pipes] Load v1.0 starting
10:26 [Info] [Sync Pipes] Failed to read pipe 7061832936461283346(76561############)
10:26 [Info] [Sync Pipes] Failed to read pipe 12081949291580372420(76561############)
10:26 [Info] [Sync Pipes] Successfully loaded 19 pipes
10:26 [Warning] [Sync Pipes] Failed to load manager [80199887 - QuarryOutput - ]: Container not found
10:26 [Warning] [Sync Pipes] Failed to load manager [11553559 - General - ]: Container not found
10:26 [Warning] [Sync Pipes] Failed to load manager [11556375 - General - ]: Container not found
10:26 [Info] [Sync Pipes] Successfully loaded 24 managers
10:26 [Info] [Sync Pipes] Load v1.0 complete

Merged post

Also can you let me know what mods you are running on your server in case one of those is conflicting.

https://pastebin.com/5gsATDXt

Says it's 0.9.22 still?

Just realised I've been adjusting the link test and not the link itself.
Try this link:
https://umod.org/plugins/SyncPipes.cs?version=0.9.24&branch=debug

Merged post

Having posted that last message I've realised that the link editor in the forum ignores changes to the address (now edited through source view so it should be correct)