Chat messages not showing in Rust
OxiniX
Hi dev,

Plugin is not working anymore since last force wipe, was waiting for an update before i wanted to leave a message here.
We were using this with all our staff members but currently we can't

It doesnt give any error, in console i can see my message but not in game anymore.

Thank you in advance.
Wulf
uMod Admin
Looks like it needs the chat channel addition for the Rust-specific code it uses @LaserHydra.

Replace:
 (player.Object as BasePlayer).SendConsoleCommand("chat.add", new object[] { player.Id, covalence.FormatText(formattedMessage) });

With:
 (player.Object as BasePlayer).SendConsoleCommand("chat.add", new object[] { 2, player.Id, covalence.FormatText(formattedMessage) });​
OxiniX
Original Poster
Hi Wulf,

Thank you for your response, i tried the code by replacing it, but it's not working also no errors in my console.
Wulf
uMod Admin
Unsure then, as what I provided about would be what is used now and the only issue I see with it.
bart
solved my probleme , i think teh problem come from the new team chat , maybe you should put this fix in an update , awesome work dude , much luv
OxiniX
Original Poster
Hi bart,

due your response i checked again, and it's for sure working, for some reason when i copy pasted it added a weird icon into the plugin what causes error.

so it works thank you Wulf:)
bart
have you granted teh oxide permission and instaled all the plugin referenced as "working with " ?
OxiniX
Original Poster
no no it's working, when i copied and pasted the code from wulf, it took some weird icon with it since my ftp software doesnt support some icons for some reason, but it's all fine now :) tried again by just adding 2, right after your message :)