Argument `#1' is missing `ref' modifierFixed

As title says. The console error I am getting is: "failed to compile",  error CS1620 "argument #1 is missing ref modifier" 

Same here im afraid:

Error while compiling: VehicleLicence.cs(1940,74): error CS1620: Argument `#1' is missing `ref' modifier

yup same here, can we please get an update. thanks.

+1 - Update is required.

+1 Update is required.

line 1937

trainEngine.SetTheRestFromFrontWheelData(trainEngine.FrontTrackSection, trainEngine.FrontTrackSection.GetPosition(trainEngine.FrontWheelSplineDist));

 

change too

 trainEngine.SetTheRestFromFrontWheelData(ref splineResult, trainEngine.FrontTrackSection.GetPosition(trainEngine.FrontWheelSplineDist));
                    
and any RelationshipManager.Instance to RelationshipManager.ServerInstance 
 
Until author updates 
BiXa3lVYbTTPXJ1.png MikeHawke

line 1937

trainEngine.SetTheRestFromFrontWheelData(trainEngine.FrontTrackSection, trainEngine.FrontTrackSection.GetPosition(trainEngine.FrontWheelSplineDist));

 

change too

 trainEngine.SetTheRestFromFrontWheelData(ref splineResult, trainEngine.FrontTrackSection.GetPosition(trainEngine.FrontWheelSplineDist));
                    
and any RelationshipManager.Instance to RelationshipManager.ServerInstance 
 
Until author updates 

Thanks.

thanks, and for people who have more plugins 

if its not updated yet do the same to that plugin regarding the 
RelationshipManager.Instance to RelationshipManager.ServerInstance 

 

I've updated the plugin, this issue should be fixed now!

With the latest update, I get a "you do not have permission to use this command" whenever trying to spawn vehicles. When just typing /spawn or /buy, it says "these are the available commands", but doesn't list any commands.

Seems something goofed with the update, unless I overlooked something.

Are you sure the permissions are granted correctly?

Nix that. My data file got corrupted. Deleting that and reloading plugin got it working properly. Thanks Blue.

Locked automatically