Server Updating Error

Just saw an update that Valheim just released..

I've got a server on ubuntu and all i did was ( umod update )

This is what i've got when i tried to update..

[uMod] 03:44 PM [Error] No resource available to update for package games/valheim (pre-release: no)
[uMod] 03:44 PM [Error] Core update failure

Also tried opening the server using the ( umod launch (-l) )
but i've got the same results.

May i ask if there is a problem with the seeding or..??

Problem no2 ..

Also i've been using an other (seed) that it was easy to manage, like..

Start - Stop - Restart - Backup and i've noticed that UMOD does not have any of these commands, is there also something i can do about this or maybe sometime we will be able to have easiest access? I'm forced to run the server while placing it in the background as a proccess so i won't have any problems closing my SSH client but killing it requires me to (htop + Kill) but sometimes also not efficient cause it restarts on its own.

Thank you in advance,

You appear to be missing the -P from the command.

What do you mean mr Wulf? Umod u -p ?

Merged post

What i just did was.. umod update -P

What i've got as a response..

[uMod] 04:24 PM [Info] Core updated
[uMod] 04:24 PM [Info] Valheim server updated
[uMod] 04:24 PM [Error] Checksums do not match: umod-database.dll
[uMod] 04:24 PM [Error] Failed to download resource: uMod Database - Checksums do not match: umod-database.dll
[uMod] 04:24 PM [Error] App update failure

I am not able to launch the server so i'm having a rough time here on Discord from members xD anything we can do kinda soon?

Please run the first step from the guide to update the agent, then run the command again.

If you still have the message in the last log, try adding the force arg.

Updated Agent with :

curl -sSL | bash /dev/stdin​

I'm confused about force arg.. as a new ubuntu member i do not know exatly what to do.. May i have any tips on the commands i can use? cause this happened all of a sudden.

It should be fine after updating the agent and running the update again. The force arg is added to the update command to force the update, which you can see in the reply when updating.

Forced the update, I've got no errors this time but this..

Umod launch gives me this..

Starting server... 19: ./valheim_server.x86_64: Permission denied
Server closed unexpectedly...

Restarting server...

You'll need to set the server executable shown there as executable.

I'm making it excecutable, then im running the server and it automaticaly starts to update the server and in the end i get the same error and automaticaly turns the valheim_server.x86_64 from excecutable to nothing..

Both the .sh and the valheim server exe would need to be executable; chmod +x. If you see the same error, it isn't set as such.

I have deleted everything and installed it from 0.

.sh and valheim_server.x86_64 are chmod +x

When i run ( umod launch )

it automaticaly starts updating and downloading which results in changing valheim_server.x86_64 into no excecutable..

This happened suddenly today after updating the game..

Mr Wulf, is there any way i can get you into my desktop using AnyDesk to help me resolve it? i'd appreciate that.

Thank you

I'm not able to remote in to help you, sorry. You can try running the default .sh from the game instead if you'd like to see if that makes a difference, but otherwise there isn't anything I can do to help.

I have no idea how to do that Mr Wulf.

Sadly as a newbie user that only leaves me into one solution.. Changing seed from Umod to linuxgsm

I apologize but i can't find any of the above information useful, it results into an endless errors.. Fixing some then creating some others.

I tried Deleting everything.. Umod agent and Valheim server, when i reinstalled all i've got was the same error..

I do appreciate the time you've spent on my problem.

Thank you

There is a .sh file that comes with the server install. You can set it as executable along with the server exe and run it to see if the permissions persist.

I've already set this as an Excecutable along with the Valheim_server one..

Sadly the launch forces updates it and changes the files back to no permissions.