Chat commands not workingSolved
Hi!  I'm new in umod.

This is the first plugin I install.  Oxide configuration says it is loaded OK.  But when logged in as admin in the game I enter the following command:  /oxide.grant default economic.balance to give the permissions to the default group, but it says command unknown.  So the first question is how to give the permissions.

Although I think the plugin does not work for my server, because command /balance does not work neither as admin, as I think as admin I should not need to give me permissions, shouldn't I?

Thanks and sorry in case this is a dumb/noob question.

Regards.
You do not have Oxide installed properly then if oxide.grant does not work. Check your oxide/logs for errors.
5c2d88ae4ea06.jpg Wulf
You do not have Oxide installed properly then if oxide.grant does not work. Check your oxide/logs for errors.

Thank you for your reply Wulf.

The hosting reinstalled everything from zero just in case.

Currently I have a clean installation of the forest with oxide, as you can check it here: https://pastebin.com/Vh3ZkCNj

Now, I will paste the plugins inside the plugins folder, restart, and plugins should work as expected right?  Or do I need some other plugin for the permissions/RCON system?

Thanks!

Ah, The Forest. It isn't fully supported yet, so not everything is available for it at the moment. You can grant permissions via a plugin, but I believe the current build doesn't have core commands yet.
5c2d88ae4ea06.jpg Wulf
supported

I see.  So, is there any way to know what is available to The Forest?  Thanks!!!

EDIT: it seems there is no universal permissions plugins:

Let me know if I am wrong.
Thanks!

What is available is shown on the download page for the builds generally, but in the case with The Forest, that isn't fully correct as it's kind of in a weird stage in terms of support right now.

Permissions themselves are universal in Oxide/uMod, there is no need for a plugin for them.
5c2d88ae4ea06.jpg Wulf
Permissions themselves are universal in Oxide/uMod, there is no need for a plugin for them.
Thanks, yes, I have checked the universal download page extensively already, I know already there is not a specific page for The Forest.

Regarding there is no need for a plugin for permissions, that is good news for me, as I could not find that answer nowhere.  So, can you tell me which is the exact file where the permissions are written/configured inside the Oxide folder???

Thanks!
There aren't any plugins specifically made for The Forest, which is why there isn't a page for it. There is no physical file for permissions.
5c2d88ae4ea06.jpg Wulf
permissions
OK, so is there no way to set permissions "universally"?
For The Forest, if the commands are not working in the current build, you'd have to grant them by writing a little plugin to grant them.
5c2d88ae4ea06.jpg Wulf
writing a little plugin
OK, it's good to know that there is a possibility!  Do know any Dev that could help me in this task?  Thanks!

Merged post

Kind Devs tried to help me in this task and these were the results:

Plugin made: https://pastebin.com/5zh7qSkN  This plugins loads good, but it does not fix the commands not working, granting permissions, etc.

Another Dev told me: "the chat commands don't get fired in any way doesn't matter how they get coded.  The hook has to be fixed for anything to be working.  There are ways to make it work using plugins, but the best way is to fix it in the core so that all plugins can function like they are intended to be working.  Any developer that knows how to work with oxide 'core' can fix the problem after some debugging probably, but not everyone knows how it works."

So, in case there is some Dev "out there" interested in doing this modification, pls. let me know!

Thanks!!!

Merged post

Hi again!  I wanted to tell you that this was solved by a good Devoloper who told me how to enter commands, it is not with the "/", you have to use "!".  That is all!!!!

Thank you!
Yup, I mentioned that to "that dev" on our Discord earlier today when we were discussing the issue. Glad you got it working! It has been awhile since I've done much with The Forest.
hi Wulf, yes! he told me you advised that! Thank you Wulf!

It seems The Forest has not much "movement" nowadays, forums has little participation.  But I think it is a good game, I wonder why could be the reason!
The game is pretty limited in terms of what the server can control, and clients can control other clients in some ways that are less than desirable. There hasn't been a lot of interest, but I still work on it when able to keep it up to date with the other games.
I have a question and the reply is pretty obvious, but just in case; if I test plugins in The Forest from this portal, created for other games (rust, etc) it is a lose of time, right? there is no chance that they work in The Forest, right?

thanks
Locked automatically