Packet to large error on clientSolved
Eterniity

After recent update LustyMap throws this error every time you try to open the map. The map stays blank and image for map does not load.

Error

m33ts4k0z
Same issue here
Eterniity
Original Poster
I do not believe this to be an issue with the plugin but caused by a possible change with the update. While it may be possible to adjust the plugin it may be something out of current control of plugin devs.
m33ts4k0z
This doesn't have to do with the size or resolution of the image. Its the packet size and judging by the limit (2097152) it looks like its the default value of a (web?) request. This can certainly be adjusted client or server side with a cvar until another way to programmatically load the map through the plugin is found. But since Rust:IO is also not working, we must wait a couple of days to see how it goes.
Venedas
I'm having this issue also.  I randomly joined a bunch of other servers that normally use Lustymap and no one had it loaded. Guessing this problem is happening to all Lustymap users.
Trillz
I am getting this error from Kits also
Archer1115
Not working on my server either. I went to 3 other servers that use this plugin, and they couldn't get it working either. Any updates from plugin devs on LustyMap? Please help us. 
m33ts4k0z
This line:

CuiHelper.AddUi(player, StaticMain);

on line 786 of the plugin causes the disconnect. The static map (the big one) is causing the issue. I haven't found a way to reduce the packet size though. Maybe Wulf can help out here with this? Since CuiHelper is oxides class.

Some more digging:

new CuiRawImageComponent {Png = png, Sprite = "assets/content/textures/generic/fulltransparent.tga" },

The line above causes the disconnect. If you comment it out the big map loads but without the actual map behind but instead with all the markers.

This is oxides core function and doesnt have to do with the plugin. We definately need Wulf here :S
2CHEVSKII

If I remember correct, there is a server convar called maxpacketsize or something, not sure if it helps. 
Also, you can try lowering the size of map image and see, how it goes. 
Not really sure, that Wulf can help here, cuz all that CuiHelper does is providing ability for developers to build cui from custom objects instead of plain string.
m33ts4k0z
I have already tried to reduce both the size of the image and scale down the resolution but it didn't help. I can't find any documentation about any packet cvar. But I cant understand which packet is that? 
SlyStone
If this is what 2CHEVSKII is talking about, it may help you.
Add these convars to your server.cfg file and restart


server.maxpacketspersecond "2000"
server.maxticketspersecond "1000"
m33ts4k0z
Thanks but that didn't help either.

What about the boot.config in the server folder?

gfx-enable-gfx-jobs=
gfx-enable-native-gfx-jobs=
wait-for-native-debugger=0
scripting-runtime-version=latest
vr-enabled=0
hdr-display-enabled=0
gc-max-time-slice=3
headless=

I couldn't find any documentation about it either.
Eterniity
Original Poster

Just a heads up it appears that garry may be aware of the issue per a commit. At least I hope. It did not change in the small update but we hope for the later one.

ffjMRKB.png

m33ts4k0z
That is certainly the case. It felt like it was something they missed. We can just wait for updates to be pushed to Steam. 

Merged post

Garry told me on twitter that indeed this update will solve the issue but I don't know when it will be deployed. 
itzablindcat

I have used this plugin for several months and its excellent! However after most recent Rust Update, I'm getting an error starting as this below:

Exception: Packet was too large (2601305, max 2097152)
network.netread.start(system.intptr data, system.int32 length) (at<13ea1187c2f44ff7977ec35f0f46ee4d>:0)
(wrapper remoting-invoke-with-check) network.netread.start(intptr,int)
Facepunch.network.raknet.client.handlemessage() (at 5a796a4fe13049acb09ce69baeb71bf9>:0)
facepunch.network.raknet.client.cycle () (at <5a796a4fe13049acb09ce69baeb71bf9>:0)
client.update () (at <819f1b6d25044af28b29bdd45b21b977>:0)

I have attached an image of this as well :

8NM1OES.jpg