Double description?

Does anyone else have this issue or know how to fix it (Linux host)? For months my server description has been displaying twice and I have no idea why - I've tried putting it in the main startup parameters and I've also tried putting it in server.cfg but it always doubles either way.

I've set up a simple test server to demonstrate. Here are my startup parameters (my server.cfg is empty in this instance):

-batchmode
+app.listenip *.*.*.*
+app.port 14444
+rcon.ip *.*.*.*
+rcon.password XXXXXXXXXXX
+rcon.port 12345
+server.description "Testing"
+server.gamemode vanilla
+server.headerimage https://my.com/images/banner.png
+server.hostname "Deadlock Testing"
+server.identity stg
+server.ip *.*.*.*
+server.level "Procedural Map"
+server.maxplayers 50
+server.port 1444
+server.salt 0
+server.seed 2044858667
+server.tickrate 30
+server.worldsize 4500
-logfile 202208051247.log​

... and here is the result:

Were you using one of the DLLs that I had that patched that before?

No idea, but I'll try a fresh install from scratch and see if that works.

We had a patch that helped with that before I believe, which I can try adding again.

That would be great, thanks!

Not really seeing anything to patch necessarily, and it only seems to be an issue on the client itself sometimes.

I asked some of my players and they all see the double description. It's strange that no other server owners seem to have this. It's not a big deal anyway, just one of those minor annoyances. Thanks for checking. If I discover the cause or solution I'll let you know here.

Does it show every time your server starts, when you change it during runtime, or what?

From server start

I have this as well on my servers. Didn't really gave any attention.

old bug has been around for months now. just facepunch things

OK thanks guys, glad it's not just me then.