Couldn't load server/low.ms/square.225.sav - file doesn't exist


 I'm trying to load a flat square 1k map to build raidable bases on it but I keep getting this error when trying to load it. I'm not sure why it's looking for a save file when it's the first time I'm uploading it. I made the map on rust edit 1k map height 501 saved it, uploaded it to dropbox, and did the dl=1.  The file is called square.map so I'm not sure why it's looking for square.225.sav

I'm using a server host and we have had custom maps before, in fact, our main server is a custom map with custom monuments so I'm lost as to what's causing this

Edit: Sorry this is meant to be posted in the rust section 

I get this same message after each wipe when i change to a new map, The loading sequence will look for a saved map file for the new map and will inform you that it does not (yet) exist. its nothing to worry about and you should only see it on the first startup with the new map after that you would of course have a save file.

nMyfFlEnglczTD3.jpg pookins

I get this same message after each wipe when i change to a new map, The loading sequence will look for a saved map file for the new map and will inform you that it does not (yet) exist. its nothing to worry about and you should only see it on the first startup with the new map after that you would of course have a save file.

I understand that it does it when changing maps but the server doesn't show up on the browser or I can't connect through ip. Random seed will work 
ZurAkyLADkx0836.jpg MagnumSkyWolf
I understand that it does it when changing maps but the server doesn't show up on the browser or I can't connect through ip. Random seed will work 

Same problem here, custom maps do not load, at least the one are created before last patch (i do not test other maps, is a suppose)