Server freezing sometimes, not responding
My rust server often loses response. The CMD window is frozen, jammed, unable to operate. The CPU occupation has become 0.1%. As shown in the following picture, all players are offline and can't search the server. Only when I restart the server can I restore to normal. After a while , and then there is this problem. This problem has been bothering me for a month. I really can't guide where there is a problem. Ask for help




(07:56:36) | kelvin.92031111 with steamid 76561199011877245 joined from ip 111.242.102.6:58883
(07:56:36) | NetworkId 76561199011877245 is 30557563 (kelvin.92031111)
(07:56:36) | kelvin.92031111[76561199011877245] has spawned
(07:56:50) | kelvin.92031111[76561199011877245] has spawned

 
Don't select text or scroll in the cmd window.
Disable Quick Edit mode on that cmd window.
5df121d013ded.png runescape
Don't select text or scroll in the cmd window.
Disable Quick Edit mode on that cmd window.

Insert mode and quick edit mode are always off, but they haven't solved the problem yet

What cpu do you have?
5df121d013ded.png 逃逸
你有什么CPU?

L5630X2,I've been running the rust server for two years, and it's been very good. Since April, this kind of problem has occurred. The hardware of the server has been replaced. It's still a strange problem

 
There's your problem.
The first Westmere-based processors were launched on January 7, 2010, by Intel Corporation.​
There is a bug and servers freeze sometimes, there is nothing you can do. According to dumps and debug information with debugger attached, it is because of Rust or EAC.
Had this happen a couple times this month.  Frowny face.
ive also had this happen as well
CMD window just freezes
tomhud
ive also had this happen as well
CMD window just freezes
Zugzwang
Had this happen a couple times this month.  Frowny face.

Is there a solution? Sometimes a few times a day, sometimes a few days

As I have just said, there is nothing you can do. Actually I am not sure but you could try setting encryption to 1 which would disable EAC encryption. Let me know if it works and helps.
5b6ed4c9ac8e4.jpg 米西科斯
正如我刚才所说,您无能为力。实际上我不确定,但是您可以尝试将加密设置为1,这将禁用EAC加密。让我知道它是否有效。

我在一台服务器上设置了几台rust服务器,并且CMD窗口每天冻结几次。我必须手动重新启动它们。真烦人~~

+server.eac 1  My default parameter is 1

Encryption to 1, not EAC. And there is NO server.eac command, it does not exist. There is server.encryption, 2 is EAC 1 is Facepunch IIRC.
5b6ed4c9ac8e4.jpg misticos
Encryption to 1, not EAC. And there is NO server.eac command, it does not exist. There is server.encryption, 2 is EAC 1 is Facepunch IIRC.

Server.encryption 1, OK, let me try, thank you


 
But I've tried and I do not think it helps tho.