Group not being removed on command
i have a kit called VIP
i do /kit remove VIP

yet it does not get removed.What is the way to remove a kit completely ???
Forgot to mention that as soon as i go to remove the Kit VIP i get this error (Error in box below)

Now here is the weird issue after i type /kits and get the menu i see /kit VIP was removed (even with the error below) - but on server reboot - kit vip is back again.

I need to remove these kits as they are no longer used.

Failed to call hook 'cmdChatKit' on plugin 'Kits v3.2.93' (KeyNotFoundException: The given key was not present in the dictionary.)
  at System.Collections.Generic.Dictionary`2[TKey,TValue].get_Item (TKey key) [0x0001e] in <e1a80661d61443feb3dbdaac88eeb776>:0
  at Oxide.Plugins.Kits.cmdChatKit (BasePlayer player, System.String command, System.String[] args) [0x0072a] in <c3692ff94ab94e6ca3b4426386c6deb0>:0
  at Oxide.Plugins.Kits.DirectCallHook (System.String name, System.Object& ret, System.Object[] args) [0x0102a] in <c3692ff94ab94e6ca3b4426386c6deb0>:0
  at Oxide.Plugins.CSharpPlugin.InvokeMethod (Oxide.Core.Plugins.HookMethod method, System.Object[] args) [0x00079] in <9affce1cd15c4ec183941adef8db1722>:0
  at Oxide.Core.Plugins.CSPlugin.OnCallHook (System.String name, System.Object[] args) [0x000d8] in <4452f821def6406d834e4149849fe7ea>:0
  at Oxide.Core.Plugins.Plugin.CallHook (System.String hook, System.Object[] args) [0x00060] in <4452f821def6406d834e4149849fe7ea>:0
To make it (maybe) easier type /kit edit VIP and when the menu comes up change it to 
/kit hide true that way it wont appear in any player list, 
 Have you tried manually removing it from the DATA folder then saving and reloading kits from rcon ?.
If you want to see if /kit remove * works at all just create a random kit and then use /kit remove * to see if it will remove a non vip one ?               
Original Poster
if i remove it from the gui menu people can still type /kit vip thats the issue as its still there.
Not if you make it authlevel 2 or whatever the admin level is.
As it seems that VIP kit is a default one you can also clear all your inventory including clothing and edit the kit and choose /kit vip items and it will copy empty inventory, you can also make it "npconly" which would only make it available from a NPC corpse, There are many ways to solve the problem including setting up a permission name for it to make it unobtainable,
Original Poster
cant even make kits now without it throwing up errors.
Are you creating them in chat ?
Delete all config and data files for this plugin and remove plugin and then re install plugin and create kits in chat.
You have to have all the clothing on and weapons in the belt and everything else you want in the main inventory.
I have roughly 22 kits at the minute as I use botspawn plugin and have created kits for all the different bots,
According to the plugin docs using
/kit hide true  =  it wont appear in any list ever,
Players would be authlevel 0, vips would be  level 1 and admin authlevel 2
Original Poster
yeah im doing them in chat and on a fresh server
No kits made at moment as its fresh and creating one throws up errors in CMD window now.
I posted the errors in this post :
As you can see other people are getting the exact same issue.
it might be that i dont use a gui for the kits list,they just come up in chat when i type /kits , I have found that a few gui plugins have been having problems for a while so i dont use them or use the gui function in the plugins,
Original Poster
how do i remove the gui ???
When i create a kit i dont use the image "image http etc" to copy an image to the gui and my config file has these settings
"UI KeyBinding": "",
"Kit - Logging": false,
"Show All Kits": false,
"Background - URL": ""

So when i type /kit the only thing that shows up is a chat message showing the available kits for the player, it does not show Amin, NPC or any extra kits I give as rewards. When players log on for the first time they get the autokit (with cooldown) which is pretty basic , bow/arrows/clothing/food and some resources to get started.
Original Poster
ive never used the image ever.But when i type /kit the gui auto shows up.
So i need to change this correct 
"Show All Kits": false,

scrap that as mine is already set to false.

This is from my config file

Moderator edit: Pleae use code blocks when sharing config, data, and log files.

This is from my data folder showing one kit as an example.


"kit": {
"name": "kit",
"description": "type /kit kit, Dont waste it you only get 20",
"max": 20,
"cooldown": 28800.0,
"authlevel": 0,
"hide": false,
"npconly": false,
"permission": null,
"image": null,
"building": null,
"items": [   and a list of items in the inventory

Check your kits data and configs to see if gui is applied anywhere, other than that i have no idea and hope you get it worked out