Problem updating/compiling sourceNot An Issue
I'm posting this to help remind me how to set up a new Oxide.Rust-develop environment:

1) Download the ZIP file from git: https://github.com/OxideMod/Oxide.Rust

2) Unzip it somewhere, I put it on my desktop so you can imagine the clutter.

3) Find the Steam.ps1 file, right click to unblock it. 

4) Open Visual Studio and do 'Rebuild Soluition'

Step 3 had me in a tizzy for some time as the error in the compiler is not very useful. I tried all kinds of thing, running it in admin, reinstalling powershell. I finally ran the command manually and found that the script file was blocked.

My current issue is that any refernce to displayName of an Item I get an error:

"Error CS0012 The type 'Translate.Phrase' is defined in an assembly that is not referenced. You must add a reference to assembly 'Rust.Localization, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'."

Of course the mod will work when uploaded. I'd really like to remove this, if anyone has any idea how to fix this please let me know.
The project downloads files from Steam when build, so if that file is not referenced, then it was not downloaded or not recognized by VS yet.

Any idea how to get rid of this error when referncing displayName?

Like this:  info.Weapon.GetItem().info.displayName.english.ToLower()

for example.

According to the error, make sure you have the missing reference downloaded (which should be automatic, as mentioned).
I deleted everyting and started again and it worked.  I think executing the Steam.ps1 file manully may have caused my problems in some way.
Yeah, the Steam.ps1 is only intended to be called by the project, so unsure there.
Locked automatically