Unable to paste structures

I get part building paste with error in console

 

Exception while calling NextTick callback (InvalidCastException: Specified cast is not valid.)

at Oxide.Plugins.CopyPaste.PasteLoop (Oxide.Plugins.CopyPaste+PasteData pasteData) [0x00e9f] in <3498d7c7afa442a8ba602b07f3437154>:0

at Oxide.Plugins.CopyPaste+<PasteLoop>c__AnonStorey5.<>m__0 () [0x00000] in <3498d7c7afa442a8ba602b07f3437154>:0

at Oxide.Core.OxideMod.OnFrame (System.Single delta) [0x00051] in <50629aa0e75d4126b345d8d9d64da28d>:0

Same here

Merged post

Here's the full entry: 05/05/2022 19:18:04 | Exception while calling NextTick callback (NullReferenceException: ) at (wrapper managed-to-native) UnityEngine.Component.get_transform(UnityEngine.Component) at EntityLink.CanConnect (EntityLink link) [0x0003f] in <59239ee3e817432c8cf0f2c5f1673724>:0 at BaseEntity.LinkToEntity (BaseEntity other) [0x00054] in <59239ee3e817432c8cf0f2c5f1673724>:0 at BaseEntity.LinkToNeighbours () [0x0006a] in <59239ee3e817432c8cf0f2c5f1673724>:0 at BaseEntity.GetEntityLinks (System.Boolean linkToNeighbours) [0x0001b] in <59239ee3e817432c8cf0f2c5f1673724>:0 at BaseEntity.EntityLinkMessage[T] (System.Action`1[T] action) [0x00000] in <59239ee3e817432c8cf0f2c5f1673724>:0 at ServerBuildingManager.CheckMerge (DecayEntity ent) [0x0002b] in <59239ee3e817432c8cf0f2c5f1673724>:0 at DecayEntity.ServerInit () [0x0006f] in <59239ee3e817432c8cf0f2c5f1673724>:0 at BaseNetworkable.Spawn () [0x00035] in <59239ee3e817432c8cf0f2c5f1673724>:0 at BaseEntity.Spawn () [0x00000] in <59239ee3e817432c8cf0f2c5f1673724>:0 at IOEntity.Spawn () [0x00000] in <59239ee3e817432c8cf0f2c5f1673724>:0 at Oxide.Plugins.CopyPaste.PasteLoop (Oxide.Plugins.CopyPaste+PasteData pasteData) [0x0030f] in :0 at Oxide.Plugins.CopyPaste+c__AnonStorey4.<>m__0 () [0x00000] in :0 at Oxide.Core.OxideMod.OnFrame (System.Single delta) [0x00051] in <50629aa0e75d4126b345d8d9d64da28d>:0

Merged post

Ok I've found a solution for now. Revert back to v4.1.32 and it should work fine.

your issue is different, however thanks for the report ill take a look at why it would cause this for you. for TwoShoes its bit different tho again

Any word on what would cause this error I still cant past buildings.. It worked perfectly last wipe but now I'm having to build every town building, heli building, everything on my server taking hours of my time.    

 

 Exception while calling NextTick callback (InvalidCastException: Specified cast is not valid.)
  at Oxide.Plugins.CopyPaste.PasteLoop (Oxide.Plugins.CopyPaste+PasteData pasteData) [0x00e9f] in <c54c6127eb4245439c73ed0235bac4c7>:0 
  at Oxide.Plugins.CopyPaste+<PasteLoop>c__AnonStorey5.<>m__0 () [0x00000] in <c54c6127eb4245439c73ed0235bac4c7>:0 
  at Oxide.Core.OxideMod.OnFrame (System.Single delta) [0x00051] in <50629aa0e75d4126b345d8d9d64da28d>:0


Merged post

So I was searching on the place called google and found this bit of info same NextTick error (but with a diffrent plugin) but I dont know code so maybe it'll help you 

https://oxidemod.org/threads/exception-while-calling-nexttick-callback.17116/

Having same error whenever we try to copy and paste a really big and tall base. When we load the base data file into Fortify everything for the most part seems to be there but when we try to paste it, it's only pasting a small amount of the base or missing chucks out of it in random spots. 

Exception while calling NextTick callback (InvalidCastException: Specified cast is not valid.)
at Oxide.Plugins.CopyPaste.PasteLoop (Oxide.Plugins.CopyPaste+PasteData pasteData) [0x00e9f] in <804300a93e4045e4986f717f540bf029>:0
at Oxide.Plugins.CopyPaste+c__AnonStorey4.<>m__0 () [0x00000] in <804300a93e4045e4986f717f540bf029>:0
at Oxide.Core.OxideMod.OnFrame (System.Single delta) [0x00051] in <50629aa0e75d4126b345d8d9d64da28d>:0
Exception while calling NextTick callback (InvalidCastException: Specified cast is not valid.)
at Oxide.Plugins.CopyPaste.PasteLoop (Oxide.Plugins.CopyPaste+PasteData pasteData) [0x00e9f] in <804300a93e4045e4986f717f540bf029>:0
at Oxide.Plugins.CopyPaste+c__AnonStorey4.<>m__0 () [0x00000] in <804300a93e4045e4986f717f540bf029>:0
at Oxide.Core.OxideMod.OnFrame (System.Single delta) [0x00051] in <50629aa0e75d4126b345d8d9d64da28d>:0

Merged post

Update for my error: Misticos suggested I remove all Christmas lights on the base and sure enough this worked. No issues whatso ever now. Thanks again Misticos!

 
 
xOHSOx

Having same error whenever we try to copy and paste a really big and tall base. When we load the base data file into Fortify everything for the most part seems to be there but when we try to paste it, it's only pasting a small amount of the base or missing chucks out of it in random spots. 

Exception while calling NextTick callback (InvalidCastException: Specified cast is not valid.)
at Oxide.Plugins.CopyPaste.PasteLoop (Oxide.Plugins.CopyPaste+PasteData pasteData) [0x00e9f] in <804300a93e4045e4986f717f540bf029>:0
at Oxide.Plugins.CopyPaste+c__AnonStorey4.<>m__0 () [0x00000] in <804300a93e4045e4986f717f540bf029>:0
at Oxide.Core.OxideMod.OnFrame (System.Single delta) [0x00051] in <50629aa0e75d4126b345d8d9d64da28d>:0
Exception while calling NextTick callback (InvalidCastException: Specified cast is not valid.)
at Oxide.Plugins.CopyPaste.PasteLoop (Oxide.Plugins.CopyPaste+PasteData pasteData) [0x00e9f] in <804300a93e4045e4986f717f540bf029>:0
at Oxide.Plugins.CopyPaste+c__AnonStorey4.<>m__0 () [0x00000] in <804300a93e4045e4986f717f540bf029>:0
at Oxide.Core.OxideMod.OnFrame (System.Single delta) [0x00051] in <50629aa0e75d4126b345d8d9d64da28d>:0

Merged post

Update for my error: Misticos suggested I remove all Christmas lights on the base and sure enough this worked. No issues whatso ever now. Thanks again Misticos!

 
 
I dont have any christmas lights on my town and why would that all of a sudden make a diffrence ?