Index was outside the bounds of the array.Not An Issue

Not sure why, but when i load the plugin it keeps spamming this error every second, the changes is made still works in the vending machines

Loaded plugin Compound Options v1.1.7 by FastBurst
IndexOutOfRangeException: Index was outside the bounds of the array.
IndexOutOfRangeException: Index was outside the bounds of the array.

Sounds like an error somewhere in your changes.

weirdly enough, after the server auto restarted, the error stopped.

and i had the same settings on another server with no errors at any point :P

Might just have been a plugin hiccup or something :D

Glad it worked out, those Gremlins, you can't feed them after midnight... LOL

True haha

Same thing happened to me.
It was spamming the console.

After reboot it didnt happen.

Idk if it's because i was selling the Pure Teas in Bandit Exchange for 130 Berries.
But def that section caused it , i was able to remove those items and it stopped spamming.
Ran through json vaslidator and all checked out good, i couldn't see why it was spamming.

Saw this post and gave rebooting a try, and it worked.

Locked automatically