Can't locate NpcSpawn v2.5.5 on the internetSolved

I cant get this plugin or Crate Guarrds to work and I'm guessing it's because I have the latest version of NpcSpawn which is 2.6.0.
I have had no luck finding 2.5.5 anywhere.

Just google it, the link comes up straight away.

Kaustic, You should always use the latest version of a plugin, and not go backward, unless you're having some sort of an error or conflict.  My question is, what is Crate Guards?  I see no plugin with that name.  I do see Guarded Crates, in UMod.org, but there are no dependantcies to other .CS files.

 

This is the link to 2.55, but I don't think you need it.

https://codefling.com/extensions/npc-spawn?do=download&version=12569&csrfKey=a57e7350280cb1074153cdb7578e48e9

If you google NPC Spawns Rust Plugin - you get this page.  You can select in the changelog, different versions in case you need to revert to an older one.

To run GuardedCrates plugin you need NpcSpawn (whatever the latest version number) or it wont work, I dont know about BradleyGuards on Umod as i use a different version (which doesnt have that dependency)

I never mentioned Bradley Guards on Umod.  I said Guarded Crates (you called it Crate  Guards).  But, fine.  I understand.  NpcSpawn is a plugin from Codefling for a lot of their plugins. I downloaded to use for Zombie Horde. I have Guarded Crates, I have Bradley Guards and I have NPC Spawn 2.6.0 and everything runs fine. 

I see a couple of years ago, you had an issue with BotReSpawn and Guarded Crates, from advice that Bazz31 gave you. So, we are talking about Guarded Crate from UMod.org. 

It is empty, but I do see it down in the description.  My bad, that I didn't see this yesterday.  So, yes ... at the time, they wrote that about this in September, he wrote down the current version.  But, you should always be depending on the latest version and update them as  they change.  You can use 2.6.0 and it should work.  If it's not working, are you getting code in your RCON you can copy and paste?

Ok I got it fixed. When it say's Depends on NpcSpawn 2.5.5 that to me means install that version. I did google it and it came up with the same version I already had. Anyway the version of it was as you all had mentioned not the problem.  I was having a rather hectic day and I had missed placing the NpcSpawn.cs in the plugin folder (thought I had already done so). Thanks for your input it is appreciated. 

TheBear just an fyi, I get this when I click the link you posted "oops Something Went Wrong Please Try Again" . Trying again only get's me the same thing. 

pookins I did Google it and came up with nothing but dead link's and the above mentioned oops.

kaustic

Ok I got it fixed. When it say's Depends on NpcSpawn 2.5.5 that to me means install that version. I did google it and it came up with the same version I already had. Anyway the version of it was as you all had mentioned not the problem.  I was having a rather hectic day and I had missed placing the NpcSpawn.cs in the plugin folder (thought I had already done so). Thanks for your input it is appreciated. 

TheBear just an fyi, I get this when I click the link you posted "oops Something Went Wrong Please Try Again" . Trying again only get's me the same thing. 

pookins I did Google it and came up with nothing but dead link's and the above mentioned oops.

The reason i said "google it" was because this forum used to (maybe still does) have policy (or whatever) to not post links to other sites that developed plugins and extensions , so i still do not, I did google it several times to ensure that a link was available and it still is, that plugin has been updated but the dependency info has not , it doesnt matter as the download site would show the latest version anyway,
hope your problems are solved and if they are can you change the status to solved.

@TheBear , You didnt mention BradleyGuards but the original poster did in the first line of the post, and as you are(or should be) aware GuardedCrate needs NpcSpawn to run and is listed as a dependency on the documents page.

@kaustic "I had missed placing the NpcSpawn.cs "  LOL ... I do that all the time, too.  That's what happens when you do half of your imports  through the Host UI and the other through an File Transfer Protocol.  Actually, I found my Backpacks updated plugin in  the Oxide Folder this morning.

 

@pookins  - Sorry, I did miss the dependency, because most of the plugins I use, list the Dependency above the Documentation/Updates/License (i.e. Backpack Button)  And since I already had NPC Spawn in my folder, for Zombie Horde, when I d/l Guarded Crates years later, it just ran. I still don't see Bradley Guards listed, but the that point is moot anyway.  And thanks for the heads up on the links.  I shouldn't have done that, especially since it was a Codefling link.  That's just good manners.

Hello guys want to know do anyone have a link for NPC Spawn as I cant find one

Just Google Npc Spawn it comes right up, as it is available on another site i wont post the link as this (used to be or still) is not good policy.