Not working with tech tree?Solved

Hey, great plugin, I have been using it for a while, but then when we once wiped the server it stopped sharing blueprints that were learned by the tech tree. It still works with /bs share but not automatically. Learning through physical blueprints works fine. Idk why :C

Heres my config:

{
  "Teams Sharing Enabled": false,
  "Clans Sharing Enabled": true,
  "Friends Sharing Enabled": false,
  "Share Physical Blueprints": true,
  "Share Tech Tree Blueprints": true,
  "Allow Manual Sharing of Blueprints": true,
  "Share Blueprints on Join": true,
  "Clear Data File on Wipe": true,
  "Items Blocked from Sharing": []
}​

Will investigate the matter as seems like a weird edge case bug.

Thanks, let me know if you found out sth or if I can help you somewhere!

Could you provide answers to the following questions:

  • Which version of the plugin are you running?
  • Which clans plugin are you using?
  • Do you have any other plugins installed which alter how blueprints work?

1. I run the latest Version: v1.2.10
2. I am using the free Clans plugin from Umod from Killyou
3. I have BlueprintManager installed, I will unload it and check whether it will work after that :D



Merged post

Ok I tried it but its not the reason, after unloading BlueprintManager it still doesnt work. The thing is I didnt even changed much but then suddenly after a restart it stopped working.

I am guessing you have regular restarts scheduled so the plugin gets reloaded at some point?

Yeah exactly, daily.

Merged post

Do you have any idea if its an error on my side or the plugins? Because if its on my side I would try harder to fix it in some way.

Merged post

I found the issue... It was somehow interfering with EasyResearch by Khan. I didnt think that this was affecting the blueprints themselves, so it was kind of my bad, sorry that I took your time with that :( 

Sorry didn't get a notification about your latest response. I was struggling to replicate the issue so assumed it was more likely to be a third party plugin. Glad you managed to resolve the problem and thank you for letting me know.