Failed to call hook 'OnServerInitialized'Solved

Hi,

I'm getting the error below when I try to use my custom config. I don't want to publish it here but happy to share it. It passes json lint tests and the list of entities worked with the pre 2.0.0 version, so I'm not sure what it could be.

Morgyn

Failed to call hook 'OnServerInitialized' on plugin 'BlueprintManager v2.0.5' (FormatException: Index (zero based) must be greater than or equal to zero and less than the size of the argument list.)
  at System.Text.StringBuilder.AppendFormatHelper (System.IFormatProvider provider, System.String format, System.ParamsArray args) [0x000ff] in <fb001e01371b4adca20013e0ac763896>:0
  at System.String.FormatHelper (System.IFormatProvider provider, System.String format, System.ParamsArray args) [0x00023] in <fb001e01371b4adca20013e0ac763896>:0
  at System.String.Format (System.String format, System.Object[] args) [0x00020] in <fb001e01371b4adca20013e0ac763896>:0
  at Oxide.Plugins.BlueprintManager.GetLang (System.String langKey, System.String playerId, System.Object[] args) [0x0000e] in <3c3559d7914c4bb18d49df79e5838b31>:0
  at Oxide.Plugins.BlueprintManager.<OnServerInitialized>m__2 (System.String defaultBP) [0x00022] in <3c3559d7914c4bb18d49df79e5838b31>:0
  at System.Collections.Generic.List`1[T].ForEach (System.Action`1[T] action) [0x00024] in <fb001e01371b4adca20013e0ac763896>:0
  at Oxide.Plugins.BlueprintManager.OnServerInitialized () [0x001f7] in <3c3559d7914c4bb18d49df79e5838b31>:0
  at Oxide.Plugins.BlueprintManager.DirectCallHook (System.String name, System.Object& ret, System.Object[] args) [0x0006a] in <3c3559d7914c4bb18d49df79e5838b31>:0
  at Oxide.Plugins.CSharpPlugin.InvokeMethod (Oxide.Core.Plugins.HookMethod method, System.Object[] args) [0x00079] in <09575a60985045248bcb43b20faeeb99>:0
  at Oxide.Core.Plugins.CSPlugin.OnCallHook (System.String name, System.Object[] args) [0x000d8] in <bae5f1223fce49c493b01571c99dce02>:0
  at Oxide.Core.Plugins.Plugin.CallHook (System.String hook, System.Object[] args) [0x00060] in <bae5f1223fce49c493b01571c99dce02>:0

Add me on discord @Whispers88#0007 I'll send you a debug version so we can figure out what's causing the issue 

Merged post

Thanks v2.0.6 had the fix for this

Locked automatically