Failed to call hook 'OnServerInitialized'Solved

First, let me start out by saying this update, is AMAZING! Blew me away. LOOOVVVEEEE it!

So I just edited my config to include the items that were there before the new update, and I reloaded the plugin using the o.reload command. I got the following error.

(08:23:35) | Unloaded plugin Blueprint Manager v2.0.2 by Whispers88
(08:23:35) | Failed to call hook 'OnServerInitialized' on plugin 'BlueprintManager v2.0.2' (FormatException: Index (zero based) must be greater than or equal to zero and less than the size of the argument list.)
  at System.Text.StringBuilder.AppendFormatHelper (System.IFormatProvider provider, System.String format, System.ParamsArray args) [0x000ff] in <fb001e01371b4adca20013e0ac763896>:0 
  at System.String.FormatHelper (System.IFormatProvider provider, System.String format, System.ParamsArray args) [0x00023] in <fb001e01371b4adca20013e0ac763896>:0 
  at System.String.Format (System.String format, System.Object[] args) [0x00020] in <fb001e01371b4adca20013e0ac763896>:0 
  at Oxide.Plugins.BlueprintManager.GetLang (System.String langKey, System.String playerId, System.Object[] args) [0x0000e] in <73ebf869fa324b23983247e6a87f121c>:0 
  at Oxide.Plugins.BlueprintManager+<OnServerInitialized>c__AnonStorey2.<>m__0 (System.String bonusBP) [0x00022] in <73ebf869fa324b23983247e6a87f121c>:0 
  at System.Collections.Generic.List`1[T].ForEach (System.Action`1[T] action) [0x00024] in <fb001e01371b4adca20013e0ac763896>:0 
  at Oxide.Plugins.BlueprintManager.OnServerInitialized () [0x002b3] in <73ebf869fa324b23983247e6a87f121c>:0 
  at Oxide.Plugins.BlueprintManager.DirectCallHook (System.String name, System.Object& ret, System.Object[] args) [0x0006a] in <73ebf869fa324b23983247e6a87f121c>:0 
  at Oxide.Plugins.CSharpPlugin.InvokeMethod (Oxide.Core.Plugins.HookMethod method, System.Object[] args) [0x00079] in <09575a60985045248bcb43b20faeeb99>:0 
  at Oxide.Core.Plugins.CSPlugin.OnCallHook (System.String name, System.Object[] args) [0x000d8] in <bae5f1223fce49c493b01571c99dce02>:0 
  at Oxide.Core.Plugins.Plugin.CallHook (System.String hook, System.Object[] args) [0x00060] in <bae5f1223fce49c493b01571c99dce02>:0
(08:23:35) | Loaded plugin Blueprint Manager v2.0.2 by Whispers88

I did try and unload the plugin, edit it, and then load it, cause i figured maybe the reload command is what was causing the issue. I still get the same error.
The plugin also says that it was loaded successfully, however I go into my 'AdminMenu' (killyou's plugin on CC), and none of the permission nodes are there.

Edit: Just did some more digging... apparently you can't delete the "customperm1" and "customperm2" from the "Assign custom BP unlocks to various perms (permission, BP List" JSON object. When I was getting this error, it was because I replaced all the key value pairs in that object with just one key value named "junkpileunlocks" which the value was the array list of unlocks. I don't need anymore then just one key value pair list in this "Assign custom BP unlocks to various perms (permission, BP List" JSON object but i guess I'll just have three of them since i can't delete the custom perms ones.

Issue was because of an item that doesn't have a blueprint was in the list. Double check your lists before you reload. If the item doesn't have a blueprint (which made its way in my list somehow), then it'll throw this error.

Thanks I just posted an update 2.0.5 which should fix this. Let me know if you have any other issues and glad to hear you like the update :)

Locked automatically