Chat messages not being removed when using Better Chat
KingOfWhateverr
I had this disabled for a long time and I couldn't remember why and then I found the thread I made on this exact issue months ago and realized this is why. With Better Chat, messages don't get removed, they just lose the betterchat wrapper. I type !rules, it posts the response, and then reposts my message below it but as default chat not better chat. Works fine if I don't have it remove the message but I dislike the command spam in chat that happens occassionally.
Attached is an image of the responses with remove from chat on and off respectively. I typed !wipe then !decay and that is how the bot responds to each.

misticos

Make sure to update Better Chat and Smart Chat Bot. If this doesn't work, we should wait for an update.
KingOfWhateverr
Original Poster
Thread I made about exact issue 7 months ago:
https://umod.org/community/smart-chat-bot/8271-auto-responses-not-removed-not-working-properly-with-better-chat
If you're waiting for an update, I assume you're pushing the blame onto BetterChat's API? If so, should I go make a post on BetterChat's support forum/ping @LaserHydra?
LaserHydra
Moderator

You pinged me by asking whether to ping me :P

I updated Better Chat to provide an option to make it a bit easier to fix this.

KingOfWhateverr
Original Poster
I appreciate it but I figured pinging you was the right options, otherwise I wouldn't have actually pinged you. :P Thanks for the update.
misticos

I'll add some support for it this week.

Merged post

Should be solved @KingOfWhateverr