Not working with Groups/Clans?Solved

My user's have been reporting that the plugin does not seem to work for targetting people that are grouped up in teams/clans together?

It seems to work fine for shooting NPCs / single hostile players.. but when there is a group of people together it doesn't seem to want to target them at all, even when hostile?

Any ideas what could be causing that? Server is pretty heavily modded so I'm not discounting another mod being a culprit.. but so far I've tried temp disabling or removing any other mod I thought could conflict but the behavior seems to be the same. 

There are several plugins that can affect turret targeting, so I'm not sure off the top of my head which one it might be, but I can work closely with you to figure it out.

Have you been able to reproduce the behavior yourself? Trying to figure out if teams or clans are part of the issue or just groups of players which is pretty unlikely.

My initial guess would be that the player who placed the turret has a team/friend/clan relationship with the players not being targeted, because some sort of sharing plugin is auto authorizing them, or just preventing them from being targeted.

Well do have a numer of mods like: Automatic Authorization, Turret Manager, Clans, Friends, etc.

I haven't been able to reproduce it.. it's a hard one to test especially since it's a fairly low pop server. But I did observe it in action the other day as he one guy was driving around with 2 fully loaded turrets, they were shooting other stuff but he kept going back to this one group of 3 people in a team that was shooting at him but the turrets wouldn't do anything. He said he had no interactions or teams with them before, but this guy is the server's main raider so now I'm wondering if maybe he authed on their TC at some point or something that caused it, that might do it due to Auto-Auth.

Is this happening while the car is moving, or while stopped? If while driving, this could be due to the fact that turrets cannot track targets quickly in vanilla, meaning if the turret or the target is moving, the turret may have difficulty tracking them after acquiring them as a target. If this is the case, you will likely see the turret aiming in approximately the target's direction, or at least turning toward them, but not firing. This should not happen when driving directly toward or away from the target. If this is the issue, the Better Turret Aim plugin is the remedy which I created at the same time as this plugin.

It turned out there was an issue related to one of the hooks this plugin was using: OnTurretTarget. If there was a group of players, and a plugin blocked one of them from being targeted using that hook, the turret would not be able to target any other player nearby, until all untargetable players left the turret range. That's my best guess as to what caused this, and that was fixed in the July 2021 Oxide update, so I'll mark this Solved.

Locked automatically