Item duplication glitchNot An Issue
RusBear
That's the kind of flaw. Correct please. Overall a very good plugin thank you.  https://youtu.be/CHyb97YaFdQ.
mspeedie
Plugin Developer
hmmm.  that is serious infinite lgf.

Merged post

What version is that?  I am not able to reproduce that with the current version.  Can you shoot me your configuration and any additional steps you did to get this affect?
RusBear
Original Poster
{ "Hats do not use fuel (true/false)": false, "BBQs (true/false)": false, "Campfires (true/false)": false, "Candles (true/false)": true, "Cauldrons (true/false)": false, "Ceiling Lights (true/false)": false, "Fire Pits (true/false)": false, "Fireplaces (true/false)": false, "Fog Machines (true/false)": true, "Furnaces (true/false)": false, "Hobo Barrels (true/false)": true, "Lanterns (true/false)": true, "Refineries (true/false)": false, "Search Lights (true/false)": true, "Simple Lights (true/false)": false, "SpookySpeakers (true/false)": false, "Strobe Lights (true/false)": false, "SnowMachines (true/false)": true, "Protect BBQs (true/false)": true, "Protect Campfires (true/false)": true, "Protect Cauldron (true/false)": true, "Protect Fire Pits (true/false)": true, "Protect Fireplaces (true/false)": true, "Protect Furnaces (true/false)": true, "Protect Hobo Barrels (true/false)": false, "Protect Refineries (true/false)": true, "Devices Always On (true/false)": true, "Always On (true/false)": false, "Night Toggle (true/false)": true, "Console Output (true/false)": true, "Night Toggle Check Frequency (in seconds)": 30, "Always On Check Frequency (in seconds)": 300, "Device Check Frequency (in seconds)": 300, "Dusk Time (HH in a 24 hour clock)": 18, "Dawn Time (HH in a 24 hour clock)": 9.0}Config Now it is.At the time of the working lamp this effect.The version of the plugin with the last update.
mspeedie
Plugin Developer
I loaded your config and only loaded my plugin and did not see this behaviour.  Are you running NoFuelRequired or some other plugin that affects fuel?  This is not reproducible with the current version of the code running by itself.  There most likely is some other plugin feeding the fuel into the Lantern other than mine.
RusBear
Original Poster
AutoFuel

Merged post

{
"Settings": {
"Don't require fuel": false
},
"Types to autofuel": {
"Use Barbeque": false,
"Use Campfire": false,
"Use Ceiling Light": true,
"Use Fireplace": false,
"Use Fogmachine": false,
"Use Furnace": false,
"Use JackOLanterns": true,
"Use Lantern": true,
"Use Oil Refinery": false,
"Use Search Light": true,
"Use Skull Fire Pit": false,
"Use Tuna Can Lamp": true
}
}
mspeedie
Plugin Developer
These two plugins are not compatible.  Please use one or the other.  The same goes for EverLight and NightLanterns.  If both plugins are working on the same entity results can be unexpected.

Note you do not need any fuel for my plugin so running autofuel is not needed, and as you saw generated bad results.
RusBear
Original Poster
I wanted the fuel of all the lamps to be consumed from the tool Cupboard . It is possible to add in your plugin?
mspeedie
Plugin Developer
Ceiling Lights do not use fuel, they use electricity so I don't believe AutoFuel will work for them.  My plugin bypasses the need for electricity if you set the light source to true in the configuration.  The same is true for Simple Lights.  It is one of the added features.  I would leave Simple Lights false or you will vex folks playing with electricity.

You could just set the type to false in my config for the ones you want to use AutoFuel (Jack'o Lanterns, Lanterns, Tuna Can Lamps).  But if you do that you don't really need my plugin, do you?  That is pretty much all the light sources being covered by AutoFuel.

If you are using my plugin just to turn the lights on and off while using AutoFuel it would take away players' agency and fuel.  That does not seem very fair or nice.  The reason for my plugin not requiring fuel is so you can have the lights either always on or on at night and not take fuel away from players without their consent.  It is also efficient on the server load as there is no fuel processing per light.  If you do want lights on at night and using fuel then Night Lantern allows that configuration.