Setting up bots to spawn automatically?
This thread is stale. Please consider creating a new thread before replying to this one.
talon
I have to set zombies myself. how do you set them automatically?
Steenamaroo
Plugin Developer
Hi,
BotSpawn can spawn NPCPlayer scientists or murderers.
You can toggle between the two by setting "Murderer": true/false in the config/data profiles.
talon
Original Poster
In response to Steenamaroo (View post):
Hi,
BotSpawn can spawn NPCPlayer scientists or murderers.
You can toggle between the two b...

12:57 [Error] BotSpawn v1.8.4: Failed to load config file (is the config file corrupt?) (Error parsing boolean value. Path 'Monuments.Compound.Peace_Keeper', line 107, position 23.)
12:57 [Error] Failed to initialize plugin 'BotSpawn v1.8.4' (JsonReaderException: Unexpected character encountered while parsing value: l. Path 'Monuments.Compound.Peace_Keeper', line 107, position 23.)
this is the fault i see come up.
Steenamaroo
Plugin Developer
It's telling you where the error is there ^.
In the config folder BotSpawn.json at Monuments.Compound.Peace_Keeper.

Most likely you've dropped the comma or capitalised.

"Peace_Keeper": true,"Peace_Keeper": false,
talon
Original Poster
i found a flaw. but i can't give myself permission to use it. it says it doesn't exist.
Steenamaroo
Plugin Developer
With the error above the plugin won't be loaded.
You'd need to rectify the mistake and ensure the plugin is loaded before moving on.
talon
Original Poster
it's on my oxide/plugin and my config. list. how do i see if it's loaded?
Steenamaroo
Plugin Developer
Your console output, above, tells you it's not loaded.
If you fix the mistake in the config file (or just trash it) and reload, console should then tell you the plugin is loaded.
talon
Original Poster
I've done that. deleted and reloaded plugin and config. files. still no response.
Steenamaroo
Plugin Developer
Instructions for giving yourself the permission are in the overview.
You need to confirm, by checking console, that the plugin has loaded successfully before you can give yourself the permission.
talon
Original Poster
ok i confirmed it is loaded currectly. gameking looked into it also. still no response.

Merged post

I'm getting this fault. i can't seem to get the bot's to auto spawn. 

03:00 [Error] BotSpawn v1.8.4: Failed to load config file (is the config file corrupt?) (Invalid character after parsing property name. Expected ':' but got: ". Path '', line 2, position 2.)
03:00 [Error] Failed to initialize plugin 'BotSpawn v1.8.4' (JsonReaderException: Invalid character after parsing property name. Expected ':' but got: ". Path '', line 2, position 2.)
can you help me with this?
Wulf
uMod Admin
In response to talon (View post):
ok i confirmed it is loaded currectly. gameking looked into it also. still no response.

M...
Looks like yourconfiguration file was edited wrongly. I'd suggest making sure that the default format is followed, and perhaps check for valid JSON by using a site such as http://www.jsonlint.com